The citation appears in "heading 1 Style", how can I change it?

Nov 11, 2011 at 2:43 PM

Hi there,

I Hope you all are doing fine in your life.

When I insert a citation in a paragraph of “Normal Style”, the citation appears in “heading 1 style”!! So, I have to select it and change its style to “Normal” manually. But, when I update the fields it will return back to ‘Heading 1 Style”. However, this happen only in the document of my thesis!! i.e. if I create a new file and insert a citation there it appears normally in “Normal Style”!! So what’s wrong with my thesis document!!

Thank you.

Coordinator
Nov 11, 2011 at 4:19 PM

Are your in-text citations linked to your bibliography? If so, try disabling that link and see if that helps.

It is most likely a combination of two things. Word's built-in features and a bad style design in the template you are using. There is not much you can do to get around it. One trick which might help is to use the same macro which is used to get in-text citations in superscript and adapt it so it uses the normal style instead. The macro can be found at http://bibword.codeplex.com/wikipage?title=Styles_FAQ&referringTitle=Documentation#Q9

Nov 11, 2011 at 5:32 PM


Thenk you "Yves" for your response. Yes all in-text citetions are linked to the bibliography, but I do not know how to remove thart lik (I do not want to change them to a static text). For the case of macro, I've applied the macro, but it just changed the citation to be superscript!!!

I'm wondring why it's working fine in a new document?! but in my thesis document it is not ?

Coordinator
Nov 11, 2011 at 7:26 PM

I'm not talking about static text, I'm talking about hyperlinking in-text citations to the bibliography. Open the style and look for

<citation_as_link>yes</citation_as_link>

And change the 'yes' into a 'no'.

Of course the macro puts them all in superscript, that is its intention. I suggested you should use a macro similar to that one but with the specific properties you require. It probably is already enough if you just remove the superscript line from the macro code but you will have to experiment to see what you need exactly.

Because your thesis is based on a certain template which has specific style settings that a new blank document started from another template has not. IEEE is known for its 'buggy' template for example.

Nov 11, 2011 at 7:43 PM

Thank you so much "Yves", I'll try that later and let you know.

Regards

Nov 12, 2011 at 1:53 PM
yves wrote:

I'm not talking about static text, I'm talking about hyperlinking in-text citations to the bibliography. Open the style and look for

<citation_as_link>yes</citation_as_link>

And change the 'yes' into a 'no'.

Of course the macro puts them all in superscript, that is its intention. I suggested you should use a macro similar to that one but with the specific properties you require. It probably is already enough if you just remove the superscript line from the macro code but you will have to experiment to see what you need exactly.

Because your thesis is based on a certain template which has specific style settings that a new blank document started from another template has not. IEEE is known for its 'buggy' template for example.


Dear "yves" I did not find this 

<citation_as_link>yes</citation_as_link> 

in the citation template, however I found three of this command: 

$InTextCitationAsLink = 'true' 
 and I changed them all to false; but nothing happen.
You are right, my thesis document based on a tmplate I have created one year ago named ('Thesis Tmplate.dotx') So how can I change my thesis template to be based on normal template?.
Thnak you.
Regards,
 

 

Coordinator
Nov 12, 2011 at 2:16 PM

Which style are you using? It sounds as if you are using http://bibword.codeplex.com/releases/view/15365 which has been deprecated for over 2 years now. There is a much newer implementation at http://bibword.codeplex.com/releases/view/19764 . There you will find the citation_as_link part.

Nov 12, 2011 at 2:54 PM

Thank you for your notice.

I’ve downloaded the new one (IEEE - Alphabetical Order*) but when I insert a citation it gives me [BO] !!!

By the way, I also modified the IEEE style (the one that I’m using) to represent the in-text citation as the first three letters of the last name of the author followed by the last 2 digits of the year.

For example if a paper has the following info :

First name: John

Last: Mazak

Year 2005

The in-text citation will be [Maz05]

The way that I did that is to add the comment field to the in-text citation and the in-text shortcut will be entered manually in the comment field.

I know it’s not the healthiest way to do that, but I’m not an expert in XML.

The style that I’m using can be found in this link:

https://skydrive.live.com/self.aspx/Public/Bibliography%20style/IEEE-Tamim-Mod.XSL?cid=1c677b83b681cba7&sc=documents

What do you think that I have to do?

 

Thank you for your care.

 

 

 

 

 

Coordinator
Nov 12, 2011 at 7:20 PM

Please read the documentation! The first style you were using had been deprecated for over 2 years as the download page clearly stated. Now you are asking questions about '[BO]' which are answered in the FAQ and remarks sections on the page you got the new style from. Also, a simple search of this discussion group would have given you plenty of information on the subject...

Instead of the comment field, I would suggest using the tag field. It is what makes a citation unique. But you can of course stick to the comment field.

If you want your in-text citation the way you describe them, then you don't need an alphabetically ordered bibliography, you need a tag/comment ordered bibliography. That would mean that you don't need the extender and that you don't need the difficulties of reordering.

In the style you downloaded, look for

 <format>{%BibOrder|"BO"%}</format>

and change all occurences in either

 <format>{%Tag%}</format>

or

<format>{%Comment%}</format>

depending on where you store your tags.

Then, change all elements looking like this

 <sortkey>some data here</sortkey>

into either

 <sortkey>{%Tag%}</sortkey>

or

 <sortkey>{%Comment%}</sortkey>

Nov 12, 2011 at 8:08 PM

I'm really sorry, you'r right I had to read the FAQ and the description before asking.

I'll try what you have told me.

Thank you so much "yves" your help is appreciated.