Disabling autoformatting of links in bibliography.

May 22, 2011 at 10:08 AM
Edited May 22, 2011 at 10:09 AM

I've disabled the autoformat options in Word to stop URLs automatically hyperlinking (becoming active) in my documents:

http://www.itechtalk.com/thread7327.html

I've also tried edited the *.XSL file directly:  

<citation_as_link>yes</citation_as_link>

to

<citation_as_link>no</citation_as_link>

http://bibword.codeplex.com/discussions/257707

Neither of these solutions have worked - even when combined. I've been editing the Harvard Anglia style. Citation_as_link is already set to no.

There's three other instances of citation_as_link to be found in the *.XSL document that relate to "when test" and result in formatting the source to HTML.

I've tried changing the value of the condition and removing these blocks of codes but again, nothing works.

The hyperlinking of the the links in the Bibliography is a real problem for me. When I paste my document into a plain text file the links are pasted without the angular brackets.

Coordinator
May 22, 2011 at 3:06 PM

The first link you provide does not work.

What exactly are you trying to achieve? Your title makes me assume you are talking about URLs which are in your bibliography, yet the discussion you are pointing to is about linking in-text citations to bibliography entries. Could you clarify what you want to do?

The citation_as_link feature is intended to link in-text citations to entries in the bibliography. It has nothing to do with formatting URLs present in your bibliography. The decision on wheter an URL is formatted as a hyperlink or not in your bibliography depends on the flags which are used after the URL variable in format strings. If there is an 'l' (so %URL:l%) then hyperlinks will be made, otherwise not. In the Harvard Anglia style that flag is set.

May 22, 2011 at 4:29 PM
Edited May 22, 2011 at 4:38 PM

@yves:

First link:

You're correct about the first link not working though the link is valid. For some reason that entire website (http://www.itechtalk.com/) isn't loading. It was fine a few hours ago.

To summarise, the link explained how to disable Word's automatic activation of URL's (i.e. converting a path to a hyperlink, underline and blue rather than plain text).

Regarding bibliography links:

Again, you're correct. I was talking about URLs in the bibliography and had overlooked the fact that the article of the second link was in relation to in-text citation.

I've gone ahead and located five instances of

%URL:l

and replaced it with

%URL:

Q1: Is the ":" redundant? i.e. should I have deleting it with "l"?

Yes, this removes the link but...

Q2: How do I remove the underline?

Q3: How do apply the angular brackets to the URL? (I've tried manually adding them Word's source manager but the link doesn't show as a result).

In case you're wondering why I'm being so particular, I'm simply trying to match the PLAIN TEXT Anglia format exactly :

BibWord, 2011.  BibWord : Microsoft Word Citation and Bibliography styles - View Discussion. [online] Available at: <http://bibword.codeplex.com/>  [Accessed 22 May 2011].

Note the angular brackets without an underline or link.

What I'm trying to achieve:

I have the one Word document that I want to be able to output two copies of by tweaking the anglia.xsl file.

  1. First copy is for an electronic format e.g. PDF: In-text citations and bibliography are linked.
  2. Second copy is for print: In-text citations and bibliography are NOT linked.

I can achieve this with your answers to questions 2 and 3.

Questions 1, 4 and 5 are not essential.

Regarding in-text citation:

I have changed the value of <citation_as_link> to yes but...

Q4: Can you make any recommendations on how make this look like a conventional URL? (i.e. underlined and blue)

Q5: In your experience, is it considered better practice or convention to leave the in-text link looking like plain text?