Bibliography Style Problem

Sep 9, 2010 at 11:39 AM

Hello,

first of all thank you for your great work!! It really helped getting started using the literatur management in Word 2010.

For my disseration I need a format like the following in the biblography:

[Parasuraman et al., 2000]
       R. Parasuraman, T.B. Sheridan & C.D. Wickens (2000). A model for types and levels of human interaction with automation. In: IEEE Transactions on Systems, Man and Cybernetics, Part A, 30(6), S. 286-297.

Thus the %Last% author and "et al." if more than one author and the year shall be displayed in the first line.
In the second line, all authors shall be named with their first names. This line shall also be indented.

I managed to get the format so far with:

<columns>1</columns>   <!-- Use paragraph style formatting -->

<format>[{%Author:2%}{, %Year%}]&lt;br/&gt;{%Author:1%}{. %Title%}</format>

but in the second line, the authors are not shown as %Author% has already been used .... is there any way to cope with this??

I tried to create a list name "SecLineAuthor" in <namelists>

<list name="SecLineAuthor" id="1">
        <single_prefix></single_prefix>
        <multi_prefix></multi_prefix>
        <corporate>{%Corporate%}</corporate>
        <first_person>{%First:d% }{%Middle:d% }{ %Last%}</first_person>
        <other_persons>{%First:d% }{%Middle:d% }{ %Last%}</other_persons>
        <separator_between_if_two> and </separator_between_if_two>
        <separator_between_if_more_than_two>, </separator_between_if_more_than_two>
        <separator_before_last>, and </separator_before_last>
        <max_number_of_persons_to_display>5</max_number_of_persons_to_display>
        <number_of_persons_to_display_if_more_than_max>1</number_of_persons_to_display_if_more_than_max>
        <overflow> et al.</overflow>
        <single_suffix></single_suffix>
        <multi_suffix></multi_suffix>
</list>

and use it in the format string for the biliography:

<format>[{%Author:2%}{, %Year%}]&lt;br/&gt;{%SecLineAuthor:1%}{. %Title%}</format>

but without luck ... didn't work ....

I would really appreciate any hints !!

best regards,

 

Mike

Sep 9, 2010 at 12:17 PM

Hi,

I got a bit further:

using %Author:r" allows multiple use of parameter ...

the last remaining "problem" is the indetation for the second line ... I tried &nbsp; ... no luck ... anyone any ideas??

 

best regards,

Mike

Coordinator
Sep 9, 2010 at 2:12 PM

You could trick BibWord into using 2 paragraphs for a single entry. BibWord wraps the data into a paragraph by placing <p> and </p> around it. You can place close the current paragraph and open a new one inside your format string.

<format>[{%Author:2r%}{, %Year%}]&lt;/p&gt;&lt;p class='msobibliography' style='text-indent:20;'&gt;{%Author:1%}{. %Title%}</format> 

The text-indent style guarantees that your text is indented, while the msobibliography class ensure that everything is formatted the same (font, size, ...)

Coordinator
Sep 9, 2010 at 2:55 PM

Alternatively, you can use any type of space which doesn't get cleaned up, like x2002:

<format>[{%Author:2r%}{, %Year%}]&lt;br/&gt;&#x2002;&#x2002;&#x2002;&#x2002;&#x2002;{%Author:1%}{. %Title%}</format>
Sep 9, 2010 at 3:45 PM

Yves,

thanks a lot for your quick replies! What happens now is as follows:

[Cox & Wilfong, 1990]
     Ingemar J. Cox & Gordon T. Wilfong (1990). Autonomous robot
vehicles
. Berlin, Heidelberg: Springer.

The second line starts indented, but when the paragraph wraps it starts again at the beginning of the line. This is how I'd love to have it:

[Cox & Wilfong, 1990]
     Ingemar J. Cox & Gordon T. Wilfong (1990). Autonomous robot
     vehicles
. Berlin, Heidelberg: Springer.

 

Any ideas?

 

best regards,

Mike


Sep 9, 2010 at 3:51 PM

Hi Yves,

found it!!

"text-indent:value" -> "margin-left:value" did the trick!

Thanks again!!

 

best regards,

Mike

 

 

Sep 9, 2010 at 7:59 PM
Did that and works like a charm !!!

Thanks a lot for your wonderful project and your help!!!

I really appreciate it!!

best regards,

Mike


> From: yves
>
> That was not what you posted in your original example :-)Anyway, use the
> extra paragraph example, but instead ofstyle='text-indent:20;'try using
> something likestyle='margin-left: 2em;'Of course, in a rtl world, that
> would become margin-right.
>
>