2 small changes needed - help required

Aug 23, 2010 at 7:50 PM

First off, this is a fantastic piece of software and has saved me so much time.


I'm making changes to the Harvard - Exeter style as its extremely similar to my university's style.

There are 2 small changes I need to make to the web site reference.

"Available:" needs to change to "Available from"


The URL should be encapsulated in <>


I've been trying to edit the styles on my own, but when I use bibword extender to reload the styles my new one doesn't show up. Can someone please help?



Aug 28, 2010 at 9:08 AM

Regarding 1:

A simple find/replace operation in the xslt should do the trick:

  • find what (without the quotes): "Available:"
  • replace with (without the quotes): "Available from"

Regarding 2:

There seems to be an inconsistency in the current style on how URLs are displayed (some are shown as hyperlinks and some aren't). As soon as I have some more time, I will look into this. But for now, you could do the following two find/replace operations in the xslt:

  • find what (without the quotes): "%URL%"
  • replace with (without the quotes): "&lt;%URL%&gt;"


  • find what (without the quotes): "%URL:l%"
  • replace with (without the quotes): "&lt;%URL:l%&gt;"

    Let me know if that doesn't fix the issue.

  • Sep 27, 2011 at 3:19 PM


    I did not want to start a new topic, so i decide to write in this old one. Sorry for any inconvenience.

    I have similar problem. I'm modified MHRA Footnotes with the same reason as rober159. Now i have only problem with URLs. In line wchich starts: source type="InternetSite" i tried to modify on many different ways "%URL%". It seems that when i use option L i can't change any citation values like pages. In any other ways i cant display full http link encapsuled in <>. For now i just type "&lt; %URL% &gt;" but it brakes the line where link starts.

    Sep 27, 2011 at 5:52 PM

    What do you mean by "i can't change any citation values like pages"? What are you doing exactly to try to change those values?

    Sep 29, 2011 at 5:11 AM

    When I've added my citation i tried to edit values of this citation. There should be options like suppress year, author etc. and there i usually can type pages for this citation. For Internet site (even before editing in xsl file) i click on citation and there is no options like edit citation or edit source. I even can't convert it to static text. It happens only when I add URL adress to the source. I tried to modify xsl to handle this issue, but any methods i used won't let me avoid this problem. For now i just type space to separate "<>" from "%URL%".

    Thanks for help

    Sep 29, 2011 at 10:58 AM
    khuzzuk wrote:

    There should be options like suppress year, author etc. and there i usually can type pages for this citation.

    No there shouldn't be. The context menu of hyperlinking takes precedence over all other context menus.

    Try placing your outside any hyperlink in your in-text citation and then right-click so the normal context menus can be displayed.

    Tip: if your citation is something like (1, 2) then you can show the context menu for the first one by putting your cursor between "1" and "," and for the second one by putting your cursor between "2" and ")".

    Sep 29, 2011 at 11:32 AM

    My citation don't contain any hyperlinks. I just type URL in source manager and then i just place citation. When i click on it i can get to "citation options", but there is only two out of four - there is only "convert to static text" and "actualize sources". There should be also "edit source" and "edit citation". For some reason a can't get those two. There is no context menu of hyperlink becouse i dont have any of them. In xsl file for citation i use option "%URL", not %URL:l%". When I try to use "&lt;%URL%&gt;" then in citation there is no URL at all, but when i use "&lt;%URL:l%&gt;" i cant modify citation options which i described before. It is no an hyperlink issue.

    Sorry for unclear explanation of my problem.

    Sep 29, 2011 at 12:28 PM

    Which version of Word are you using? Because I have never seen the exact term 'actualize sources' on any Windows version.

    The fact that you don't see any hyperlinks doesn't mean they aren't there. For example, if you would be able to ctrl+click the in-text/footnote citation to get to the bibliography then there would be a hyperlink there.

    Instead of "&lt;%URL%&gt;" try using "&lt;&lt;span/&gt;%URL%&gt;". This was a fix introduced in the mainline BibWord releases (non footnote) a while ago.



    Sep 29, 2011 at 1:04 PM

    Thank you very much. This solution solved the problem completely. I'm using polish version, so i don't know exact source naming of options, this was my free translation. There was no hyperlinks, i know about those formated as normal text, but ctrl+click didn't result in any way. This was probably bug and it is now fixed with your trick.