ACM Alphabetical update issues (closed)

Nov 12 at 1:16 AM
Hello,

I am trying to work with the ACM style sheet as they have added both online documents and films to their list of reference-able formats. However, when I edit the code;

Line 44
<source type="InternetSite">
<b:ImportantField>b:Author/b:Author/b:NameList</b:ImportantField>
    <b:ImportantField>b:InternetSiteTitle</b:ImportantField>
    <b:ImportantField>b:Year</b:ImportantField>
    <b:ImportantField>b:Month</b:ImportantField>
    <b:ImportantField>b:Day</b:ImportantField>
    <b:ImportantField>b:URL</b:ImportantField>
    <b:ImportantField>b:DayAccessed</b:ImportantField>
    <b:ImportantField>b:MonthAccessed</b:ImportantField>
    <b:ImportantField>b:YearAccessed</b:ImportantField>
  </source>
line 151
<source type="InternetSite">
    <format>{%CitationPrefix%}%BibOrder|"BO"%{%CitationSuffix%}</format>
  </source>
line 242
   <source type="InternetSite">
    <column id="1">
      <halign>left</halign>
      <valign>top</valign>
      <format>%BibOrder|"BO"%</format>
    </column>
    <column id="2">
      <halign>left</halign>
      <valign>top</valign>
      <format>{%Author:1%.}{ %Title|ShortTitle%}{. &lt;i&gt;%PeriodicalTitle%&lt;/i&gt;{, %Volume%}{, %Issue%}}{ ({%Month:s% {%Day%, }}%Year%)}{, %Pages::%}.{ %Comments%.}</format>
    </column>
    <sortkey>{%Author:0%}{ %Title:a|ShortTitle:a%}{ %PeriodicalTitle:a%}{ %Year%}</sortkey>
  </source>
I know my formatting for how it should present in 242 is off and I'm ok with that. I can't even get the fields to appear in word when I check the format as important fields, if I select all fields I still get the unsupported error. I realize no one has updated this in a while but I'm ok doing the work if I can get past this roadblock.

Additionally, ACM inline citation should be [Author Last Name Year] not a numbered citation, how would I correct that? Thank you all.
Marked as answer by RedHatPh8 on 11/11/2016 at 8:07 PM
Nov 12 at 1:35 AM
SO I'm kinda an idiot, most of my code worked once I ensured it was in the roaming folder saved correctly as an xsl instead of the xml or xsl in the root folder. So if you are using 2016, it's important to use the correct folder.

I will keep reading the threads to see if I can find a way to change the inline citations.
Marked as answer by RedHatPh8 on 11/11/2016 at 8:07 PM