Change parentesis to superscript?

Sep 18, 2012 at 11:14 PM

I don't see the option for superscript for this source ABNT NBR 6023:2002*

How can I change it so that instead of parentesis it shows the citation numbers in superscript format?

Coordinator
Sep 19, 2012 at 9:03 AM

Check the FAQ, more specifically:

for removing brackets and putting stuff in superscript.

But honestly, I don't really understand what you are trying to do. ABNT is an author based style, not a number based style. It sounds like you are asking to fit a square block into a round hole... Changes are going to be way more extensive then you expect. For example, author based styles just have a simple paragraph layout for a bibliography whereas number based styles use a table layout where the first column contains the number and the second the entry. You would be better of starting from a numbered style like IEEE or others and adapt the bibliography formatting for those to fit your needs.

 

 

 

Sep 19, 2012 at 1:57 PM

Yves,

I have an ABNT manual that says that it is possible to use two formats for citations.  Your pluguin shows only numbers in parentesis, for instance Hello World (1), but not in superscript format such as Helo World 1 which is another format acceptable by ABNT NBR 6023:2022

I just prefer the second option as it is more readable. But from what I understood you're saying it is too complicated to implement. If that is the case I just have to use the first option.

Thank you

Rod

Coordinator
Sep 19, 2012 at 2:44 PM

Sorry, I misread because your link points to the author based version. If you downloaded the reference order based version (numerical version from http://bibword.codeplex.com/releases/view/27212) then the two links I posted from the FAQ should solve your issues. First one tells you how to remove your brackets, second tells you how to get them as superscript (and works around the bug in Word).

Sep 19, 2012 at 3:07 PM

Thanks I am already using both of them, specially the alternative,  and none have option for superscript like you're saying. At least not by default.

Coordinator
Sep 19, 2012 at 3:58 PM

It is not possible by default. That is a limitation of Word, not of the xslt.

I had lengthy discussions about this with people from MS. They claim it should work but they never provided any proof. I did illustrate that each of their suggestions (just use the superscript tag, use a span, ...) do not work for in-text citations. They do work perfectly fine for bibliographies but not for in-text citations. I went the extra mile and even tried some funky things like overwriteing one of the working tags (e.g. b)

For now my best guess is that the problem is situated around the font sizing which for some reason can't be overridden. And you need to lower the font size to display superscripts.

I do believe that their might be a more permanent solution but without an explaination on how the sanitization of the html is done inside Word, it is almost impossible to guess. And I doubt they will give me a peek at the source code :-)

So you are stuck with the workaround from the FAQ. If you run it only once at the end of your document it is enough, so it is not that much of an issue.

Sep 19, 2012 at 4:06 PM

Thanks Yves.