This project is read-only.

Trouble with IEEE style citation

Apr 22, 2011 at 5:35 PM

Hello everyone,

I'm having trouble whenever I use either the  IEEE - Reference Order style or the just the older IEEE style in Word 2010. All my sources are in place but whenever I try to insert a citation into text, it does not include an index (reference) number.  All it shows is "[]". In the source manager it does show in the current list, the citation number with each entry (e.g., Citation: [3]) but in the Master list it displays the citation as just [[index].  I toggled the code in the document and it appears to show the correct field code, (e.g., " {CITATION RCH98 \1 1033}. I've troubleshooted and few things and cannot figure out what is going on. It worked fine when I did it in Word 2007. Any suggestions to fix the issue? 


Apr 23, 2011 at 9:31 AM

Does it work with the styles which come with Word 2010 out of the box? Especially check with "ISO 690 - Numerical Reference".

Apr 23, 2011 at 7:43 PM

Thanks for the reply. Yes, it actually puts in a physical number in the "in text" citation, e.g.  "(2).  But even with the ISO 690 Numerical Reference, the source manager still displays the same results as before in the master/current list.  What does it mean then that the ISO 609 Numerical puts in an index number? I guess that is good but I do not want to use that particular style.


Apr 23, 2011 at 10:39 PM

The behaviour displayed by the source manager is normal. You should see "index" when using the master list instead of a number.

The fact that ISO 690 displays the entries correctly implies that there is nothing wrong with input to the stylesheet.

Have you by any chance changed something to the stylesheet. The only thing I can think of is that a {} or % is unbalanced in the format string for the in-text citation. Try downloading the stylesheet again and replacing your current one.

Apr 23, 2011 at 11:30 PM

Hi yves,

No, I did not change anything in the stylesheet--I know better!  Anyway, I tried re-downloading and replacing the current sheets...still to no avail.  It's weird, again, only the "[]" shows in the text without the citation, but when I toggle the code,  the correct citation reference shows up. Apart from the IEEE and ISO Numerical styles, the other defaults work fine but they don't provide a numerical reference. This is frustrating, perhaps it's just another one of those MS Word mystery issues. If you can provide any further troubleshooting steps or suggestions that will be great.


Apr 24, 2011 at 9:04 AM

Are you now saying that the ISO Numerical style which comes with Word doesn't work correctly either? From your previous posts I tought it did work. If the ISO 690 Numerical style isn't working correctly either, then the problem isn't with the stylesheets but with Word. Something must be wrong with the installation. Except for an uninstall followed by a reinstall there is nothing I can suggest in that case.

Apr 24, 2011 at 6:24 PM

My apologies...I miss typed...I meant to say, "Apart from the IEEE, the other defaults work fine but they don't provide a numerical reference. Of course the default ISO Numerical style works fine."