IEEE reference order

Feb 5, 2011 at 12:31 PM

First of all, very great job!

I have two things witch confused me (IEEE reference order):

1) The authors list. In another discussion you wrote that if there are more than 5 authors, only the first is mentioned followed by et al. That's how it is implemented in the style sheet. But if you look into the standard: http://www.ieee.org/documents/ieeecitationref.pdf it should be only 3 ?!?!?

2) When creating the bibliography I get a "x" at the beginning and one at the end. Why is that?

Bibliography 

x

[1]

C. Bur, P. Reimann, M. Andersson, A. Schütze, and A. Lloyd Spetz, "Increasing the Selectivity of Pt-Gate SiC Field Effect Gas Sensors by Dynamic Temperature Modulation," in Proc. IEEE Sensors, Waikoloa, USA, 1-4 Nov. 2010, pp. 1267-1272.

x

 

In the source code it is in line 905 and 922

<!-- Empty paragraph hack for table. -->
    <p style="display:none;">x</p>

 

 

Thanks

regards

Christian

Coordinator
Feb 5, 2011 at 2:55 PM

1/

It seems to depend on the source. According to the updated templates at http://www.ieee.org/conferences_events/conferences/publishing/templates.html there appears no longer to be a limit on the number of authors to display. And if a limit would be imposed, it would be 10 (according to the bst files on that page). I will see if I can find someone at IEEE to confirm the exact number and update the style accordingly.

2/

The x's are normally marked as hidden text. If you disable the showing of non-printing symbols in Word, you shouldn't see them.

The x's are there as a workaround for a bug in Microsoft Word. If the stylesheet returns nothing but a table containing your bibliography, Word will automatically put an empty paragraph before and after your bibliography. By wrapping your table in between two non-empty paragraphs, Word won't add the empty paragraphs. As the paragraphs have to be non-empty, I simply added an x in them (a space won't work) and marked the entire paragraph as hidden.

Feb 5, 2011 at 4:10 PM

thank you very much!

Another thing:

I've seen in the source code that there is a source type called "Thesis". How can I activate this?

Probably, I have to modify the BIBFORM.XML and add some more lines in IEEE_Reference.xsl" to define the important field?!?

I tried the BibType tool, but it seems like it doesn't work. Only for a short time the command window appears but nothing happened (I think). I'm using Windows 7 64bit, is that maybe the problem with the tool?

 

Thanks again