IEEE - Reference Order with Field Functions

Jan 7, 2011 at 4:52 PM

Hey guys,

I've got the problem, that when I'm using the IEEE - Reference Order style in my Word 2010, there is no possibility that the things form the field function, e.g. " CITATION Zdz08 \p 12 \l 1031 \f "vgl. " ", are shown.

Normally, with other styles, there must be a reference looking like this: [vgl. 1 S. 12]. What's the reason for this?

The greatest thing would be, if anyone could tell me, how to format the style, that a reference is looking like this. [vgl. 1, S. 12]

 

I hope you can help me guys :)

Coordinator
Jan 7, 2011 at 5:52 PM

You are seeing the actual field code rather than the result of it. Switch the view.

http://office.microsoft.com/en-us/word-help/field-codes-in-word-HA010100426.aspx

 

Jan 7, 2011 at 6:01 PM
Edited Jan 7, 2011 at 6:03 PM

That's not the problem!

With "CITATION Zdz08 \p 12 \l 1031 \f "vgl. " "" in the field function, I'll see "[1]" in the document using the IEEE reference style.

Using the ISO690 numerical style I'll see this (with the same code within the function): (vgl. 1 S. 12)

I want to modify the IEEE style in this way to get something looking like this: [vgl. 1, S. 12]

 

so what's the problem?

Coordinator
Jan 7, 2011 at 6:05 PM

None.

IEEE does not require you to set anything in front of the number neither does it require you to set a page after it. Hence that is not included in that particular style. You could easily adapt it to fit your needs, just check the manual for the variables CitationPrefix and CitationPages.

Jan 7, 2011 at 6:09 PM

But sometimes I want to write something in front of the number!

My question is, why it is not shwon with this style? With other styles it works fine!

Coordinator
Jan 7, 2011 at 6:13 PM

Because that style doesn't implement it. IEEE has no need for anything in front of it, so nothing is there.

If you want it, just add the CitationPrefix and CitationPages variables to the format strings and you should be good to go. You can also get them from another style like Nature which does support them.

Jan 7, 2011 at 6:16 PM

Ok, I understand.

But I'm not familiar with XML. So maybe you could give me the code segment for this?

Thx

 

Jan 7, 2011 at 6:36 PM

I got it :)!! Now it looks like this: [vgl. 1, p. 12]

 

But how could the p. for Page converted to S. (german -> Seite)?

 

thx

Coordinator
Jan 8, 2011 at 9:31 AM

BibWord styles are language independent. If you always want an S. with your pages, you can specify that in the format string.

%CitationPages:S. :S. :%

This will display 'S. ' in front of both single pages and page ranges. Actually if you always wanted vgl. in front of your number, you wouldn't have to use the prefix. You could simply write

{vgl. %RefOrder%}

as format string. So in the end, your format string could look like:

<format>{%CitationPrefix%}vgl. %RefOrder%{, %CitationPages:S. :S. %}{%CitationSuffix%}</format>
Jan 8, 2011 at 10:40 AM

Thank you, now it works great, except one thing: Now when I click on the drop-down menu from a citation, there is no more the option to modify the citation (in german: "Zitat bearbeiten"). What's the reason for this?

 

Here is the code-snip you have to replace within the original IEEE reference style xml:

<source type="Placeholder">
        <format>{%CitationPrefix%}%RefOrder%{, vol. %CitationVolume%}{, %CitationPages:p. :pp. %}{%CitationSuffix%}</format>
      </source>
      <source type="Book">
        <format>{%CitationPrefix%}%RefOrder%{, vol. %CitationVolume%}{, %CitationPages:p. :pp. %}{%CitationSuffix%}</format>
      </source>
      <source type="BookSection">
        <format>{%CitationPrefix%}%RefOrder%{, vol. %CitationVolume%}{, %CitationPages:p. :pp. %}{%CitationSuffix%}</format>
      </source>
      <source type="ConferenceProceedings">
        <format>{%CitationPrefix%}%RefOrder%{, vol. %CitationVolume%}{, %CitationPages:p. :pp. %}{%CitationSuffix%}</format>
      </source>
      <source type="Film">
        <format>{%CitationPrefix%}%RefOrder%{, vol. %CitationVolume%}{, %CitationPages:p. :pp. %}{%CitationSuffix%}</format>
      </source>
      <source type="InternetSite">
        <format>{%CitationPrefix%}%RefOrder%{, vol. %CitationVolume%}{, %CitationPages:p. :pp. %}{%CitationSuffix%}</format>
      </source>
      <source type="JournalArticle">
        <format>{%CitationPrefix%}%RefOrder%{, vol. %CitationVolume%}{, %CitationPages:p. :pp. %}{%CitationSuffix%}</format>
      </source>
      <source type="Misc">
        <format>{%CitationPrefix%}%RefOrder%{, vol. %CitationVolume%}{, %CitationPages:p. :pp. %}{%CitationSuffix%}</format>
      </source>
      <source type="Patent">
        <format>{%CitationPrefix%}%RefOrder%{, vol. %CitationVolume%}{, %CitationPages:p. :pp. %}{%CitationSuffix%}</format>
      </source>
      <source type="Report">
        <format>{%CitationPrefix%}%RefOrder%{, vol. %CitationVolume%}{, %CitationPages:p. :pp. %}{%CitationSuffix%}</format>
      </source>
      <source type="Thesis">
        <format>{%CitationPrefix%}%RefOrder%{, vol. %CitationVolume%}{, %CitationPages:p. :pp. %}{%CitationSuffix%}</format>
      </source>

Coordinator
Jan 8, 2011 at 11:09 AM

It is still available but access to it is partially overwritten by the hyperlinking feature. Place the cursor after the citation and before the closing bracket. Then right click and the option should be available. So e.g. [vgl. 5, S. 12<cursor here>] and [vgl. 5, S. 12<cursor here>; vgl. 6, S. 13<cursor here>]

Alternatively, if you don't need the hyperlinking feature, just disable it in the code by changing the value from yes to no (<citation_as_link>yes</citation_as_link>).