Harvard style for Word 2011 Mac?

Jan 5, 2011 at 3:25 AM
Edited Jan 5, 2011 at 3:27 AM

I need the Harvard referencing style for my university work but I cannot find it in Word 2011.  I have tried various files but nothing works.  My university has an installer for the PC version of Word 2010 to add this referencing style but nothing for Mac.  I even tried copying the PC XSL file from said reference style to the Mac version of Word 2011 but it did not work.  Can anyone make or provide me with a working Harvard style for Word 2011?  I also looked on this site, installed all current Mac styles and Harvard is there but has an asterisk next to it which means that it needs additional software and I do not know how to install this on Mac.

If it helps the university in question is Sheffield Hallam in the UK.

Many thanks.

Ian

Coordinator
Jan 5, 2011 at 7:32 AM
I even tried copying the PC XSL file from said reference style to the Mac version of Word 2011 but it did not work.

What do you mean by it did not work? Did it show up in the list of styles when you wanted to enter a citation? Or didn't you see it there? If this is the style from your university, where did they get it from (or did they made it themselves)? To where did you copy the style?

All the styles on this site are cross-platform and cross-version. That is, they work on Word 2007 (Windows), 2008 (Mac), 2010 (Windows), and 2011 (Mac).

The asteriks means you can use the additional software if you need extra functionality which is not included in any version of Word. In case of the Harvard reference styles, the additional software is only needed if you require year suffices (e.g.: Doe, 2006a; Doe, 2006b). If you don't have the same author(s) publishing multiple works in the same year, you don't need the software. If you would use it, it wouldn't do anything.

And even if you needed the year suffices and it is just one or 2 cases, you could do them manually and add the suffix after the year in the source dialog.

I would advise against installing the software on a Mac as you need an older version of Mono. The current releases of windowsbase.dll (Mono) are broken and the software will only corrupt your document! Installing older versions of Mono might (or not) harm other software.

Jan 5, 2011 at 1:19 PM

I copied the XSL file to the correct folder (right-click Word 2011 > Open Package Contents > Resources > Style) the same as I put the rest of the XSL files but it did not show once I opened Word 2011.  I believe that the university made it themselves.  The filename is 'HarvardLITS.xsl' if that helps.  I can happily email you the file in question if you would be so kind as to take a look.

Many thanks.

ianwuk

Coordinator
Jan 5, 2011 at 2:30 PM

Do the rest of the styles show?

Make sure you check both the citation style list and the bibliography style list. In Word 2008 (and probably still in 2011) there is a bug where the styles are not listed as bibliography styles but only as citation styles. See http://bibword.codeplex.com/wikipage?title=Styles_FAQ#Q2

The styles which come with Word are not portable between Mac and Windows. So if they started from such a style, you would need to change some things to make them work on a Mac.

Mail me a copy and I'll take a look but I can't promise anything. You can find my email on top of all stylesheets available on this site.

 

Jan 6, 2011 at 1:48 PM

The rest of the styles I have show up.  The file you sent me appears in the list as (Unknown).  What am I doing wrong?  Would the Word 2007 file be any different than the 2010 one I gave you and maybe work on a Mac?  Alternatively do you know how I could manually create and save the same style in Word 2011 for Mac?

Thanks.

ianwuk

Coordinator
Jan 6, 2011 at 10:50 PM

I currently don't have access to a mac so I can't test. I'll try this weekend if I can get access to one.

My first guess is that the mac is interpreting the first byte of the file (the BOM or byte-order-mark) incorrectly. So you might want to check that out already.

Yves

May 11, 2011 at 9:02 AM

Hi, I have the exact same problem as ianwuk2010, has a solution been found? I have followed the steps on your website, but for some reason absolutely nothing is showing up in Word (for Mac 2011) other than the standard ref. style that came with Word... any help??

Coordinator
May 11, 2011 at 9:10 AM

Are you sure they aren't there?

There was a bug in Word 2008 where new styles didn't show up in one place. I wouldn't be surprised if the same bug is still there in the 2011 version. See http://bibword.codeplex.com/wikipage?title=Styles_FAQ#Q2

May 11, 2011 at 12:20 PM
I may be mistaken, but I have followed the steps and copied them into the correct folder in Applications. However, when I opened it in Word and use the drop down menu for referencing they are not there. I see there are other users who have successfully installed it on Word 2011 on a Mac so there must be a solution I figure!!

ANy advice?

On 11 May 2011, at 09:10, yves wrote:

From: yves

Are you sure they aren't there?

There was a bug in Word 2008 where new styles didn't show up in one place. I wouldn't be surprised if the same bug is still there in the 2011 version. See http://bibword.codeplex.com/wikipage?title=Styles_FAQ#Q2


May 15, 2011 at 2:06 PM

I got this working pretty easily, here are the steps I followed:

  1. Unzip the Styles.zip file that you downloaded
  2. Close Word if it's open
  3. Open Applications
  4. Navigate into the Microsoft Office folder
  5. Right click on the file Word.app or just Word if you have the file extensions hidden, click 'Show Package Contents'
  6. There should now be a folder called Contents, open the folder. 
  7. Then open Resources
  8. Then open Styles
  9. Copy the Styles you want into this folder. I.e. HarvardAnglia
  10. Launch the Word application and the styles you copied in should be available. 

Let me know if that doesn't work, we can always try connect via Skype to help you out. 

May 15, 2011 at 2:09 PM

By the way, this allow you to do both bibliographies and citations. 

May 18, 2011 at 8:36 PM
Iaian,


Legend!! Sorted, thanks for your help mate.




On 15 May 2011, at 14:06, iainn wrote:

From: iainn

I got this working pretty easily, here are the steps I followed:

  1. Unzip the Styles.zip file that you downloaded
  2. Close Word if it's open
  3. Open Applications
  4. Navigate into the Microsoft Office folder
  5. Right click on the file Word.app or just Word if you have the file extensions hidden, click 'Show Package Contents'
  6. There should now be a folder called Contents, open the folder.
  7. Then open Resources
  8. Then open Styles
  9. Copy the Styles you want into this folder. I.e. HarvardAnglia
  10. Launch the Word application and the styles you copied in should be available.

Let me know if that doesn't work, we can always try connect via Skype to help you out.


May 26, 2011 at 2:24 PM

Hey guys. I go to SHU and think I've got it cracked.

Find your HarvardLITS file and open it with textedit.

First line says:         <?xml version="1.0" encoding="iso-8859-1"?>

Change this line to: <?xml version="1.0" encoding="utf-8"?>

Save and place file in the styles folder.

Hope this helps

Coordinator
May 26, 2011 at 3:28 PM

I have no idea where that HarvardLITS style comes from, but for more than 2 years all BibWord styles have been using utf-8 and are cross-platform.

Note that changing iso-8859-1 to utf-8 might work but will most likely turn up strange results with accented characters.

Sep 28, 2011 at 3:54 PM
Edited Sep 29, 2011 at 1:11 AM

"The styles which come with Word are not portable between Mac and Windows."

Ives,

I have the same problem.
I have my university style:  XSL ITTA.xsl (windows 7, in Word 2010)
But when I copy this file in world 2011 for Mac 2011, my style ITTA does not appear in the list of styles,...!!

Is in the right addressWord/Package... Contents/Resources/Style/

Coordinator
Sep 29, 2011 at 12:05 PM

If the style is a BibWord style, see http://bibword.codeplex.com/wikipage?title=Styles_FAQ&referringTitle=Documentation#Q2

If the above is not the solution to your problem and you are sure that the style you have is a BibWord style, open the style in your text editor put a space at the beginning, delete the space again (no undo) and save the document. This might force an update of the BOM (Byte Order Mark) of your file. MacOS tends to be sensitive to such things.

If the style is not a BibWord style, then you could try to change the formatting from "us-ascii" or "ISO-8859-1" to "utf-8" (just look for the strings). If you have name or titles with accents in them, that might introduce strange behaviour though.

If the style is not a BibWord style and the accents are bothering you, you could adapt the html header which is outputted. Slightly more complicated then the other solutions, but that would be the best solution (and is how BibWord does it, so you can get the correct info from there).

Oct 18, 2011 at 8:36 PM

Thank you guyz I am using a new MacBookPro Mac OS X 10.6.8 and Microsoft office 2011 and it worked!!!! following the same steps :)

  1. Unzip the Styles.zip file that you downloaded
  2. Close Word if it's open
  3. Open Applications
  4. Navigate into the Microsoft Office folder
  5. Right click on the file Word.app or just Word if you have the file extensions hidden, click 'Show Package Contents'
  6. There should now be a folder called Contents, open the folder.
  7. Then open Resources
  8. Then open Styles
  9. Copy the Styles you want into this folder. I.e. HarvardAnglia
  10. Launch the Word application and the styles you copied in should be available.
Mar 15, 2012 at 12:26 PM

Hi Guys having an issue installing this, cant get number 5, 'show package contents' am I doing something wrong? I cannot right click, as nothing happens is there another way to access this?

Nov 1, 2012 at 5:11 PM

hi guys i have word for mac 2011 and i just spent a bit of time and i think i have solved the problem... follow the instructions as they state but you then have a couple more steps... open the style icon you have just pasted into resources and find the styles you want, i copied and pasted all the harvard styles into the resources they should show as harvardanglia.xsl for example rather than  styles-1 . you now have one more step of pasting the styles you want into code resources which you can find in the selection when you open show content package. this has worked for me

Mar 31, 2013 at 8:41 AM
timurdouglas wrote:
hi guys i have word for mac 2011 and i just spent a bit of time and i think i have solved the problem... follow the instructions as they state but you then have a couple more steps... open the style icon you have just pasted into resources and find the styles you want, i copied and pasted all the harvard styles into the resources they should show as harvardanglia.xsl for example rather than  styles-1 . you now have one more step of pasting the styles you want into code resources which you can find in the selection when you open show content package. this has worked for me
I'm using mac 2011 - followed the above additional steps and it worked well for me.
thanks
Apr 26, 2013 at 11:08 AM
Edited Apr 26, 2013 at 11:10 AM
Yves, others, hi there,

I'm also using Word for Mac 2011. I'm having difficulties with the alphabetical listing of my citations using Harvard Anglia style. I've seen in another topic that there is an Adjusted version for this style that resolves this issue. I've downloaded the file that you suggested there, followed the necessary steps, and although the style appears in the citation options, it doesn't fix the listing issue.

Can anyone help me out please? I'm submitting my MSc thesis soon, so I really need to get this fixed. Thanks!:)
Nov 23, 2014 at 9:40 PM
Hi Yves,

I use Harvard - Exeter for Mac (Word 2011) and it is not working properly. I have two issues with it. One is when I have 3 or more authors, usually on Word in Windows Harvard Exeter is putting only the first Name in it and after that "et al.". Which is the correct way of citing with the Harvard style. In Mac Harvard Exeter puts me all the surnames in the text, usually you are not allowed to do so when there are more than two authors.

The other problem is, that on the end in the Reference list I have no blank line (space line) between the different books, magazines, etc.

But on a Windows Platform (Word 2010) these problems doesn't occur at all. Do you got any advice how to solve it?

Thanks
Ryu