Unsupported source type - Interviews and miscellaneous

Sep 12, 2010 at 1:03 PM


Thanks for the great work. I have just added the extra styles and the BibWord extender 2.0.

I have using the Harvard - Anglia style and need to reference some interviews and some emails (under miscellaneous).

In both in-text citation and bibliography it shows:

(Unsupported source type (Interview) for source Fer10.)

(Unsupported source type (Misc) for source Sen10)

Is there any way around this?


Thanks in advance!


Sep 12, 2010 at 4:15 PM

If you see unsupported source type messages, this means that there is no information available on how to format such an entry. I never implement types of which there is no specific defintion by the style guide because the result might or might not be correct.

Of course, if you are convinced that you know the correct way of formatting, you can always write them yourself. It shouldn't be all that hard as you have format strings for all other types at your disposal.

Dec 26, 2010 at 2:24 PM


I tried copying the interview styles from Harvard - Leeds XSLT.

Searched for the interview string and inserted the tags under importantfields, citation, bibiliography, extension tags.

However, my bibiliography shows:

Anon., 2010.

Instead of say

Smith, J., 2010. Interview with the Author on ...

Please can you help me fix this.

Dec 26, 2010 at 2:31 PM


Here's the guide to the referencing style I need to use:


Anglia seems the closest match.

Dec 26, 2010 at 2:42 PM

According to the format string for interviews in Harvard Leeds, the first field is the Interviewee. Have you actually filled in information in the Interviewee field? Or have you used Author or something else?

Also, in Harvard Leeds, the interviewee is formatted according to the specficiations for list 2 (%Interviewee:2%). Are you sure that the style you are trying to use has such a list defined?

Dec 26, 2010 at 3:01 PM


I belive I have: http://cid-666e8fd074170ae2.office.live.com/self.aspx/Public/interview-source.png

I didn't create a new style. Just copied the stuff over from Leeds. So, I belive the list 2 is defined: <list name="author" id="2"> Maybe I'm looking at the wrong place.

BTW, if I switch the referencing style to Leeds, I see

Smith, J. 2010.

only. No Interview with .. part.

Dec 26, 2010 at 3:07 PM

Add an r option after the first year variable so it can be reused.


<format>{%Interviewee:2%.}{ %Year%{%YearSuffix%}.}{ Interview with the author on{ {%Day%} %Month:s%} %Year%.}{ %City%.}{ %Comments%}.</format>


<format>{%Interviewee:2%.}{ %Year:r%{%YearSuffix%}.}{ Interview with the author on{ {%Day%} %Month:s%} %Year%.}{ %City%.}{ %Comments%}.</format>
Dec 26, 2010 at 3:31 PM

Sorry, didn't seem to help.

Still the same issue.

Dec 26, 2010 at 4:40 PM

I just tried it. Works perfectly here.

I also tried copying interview (bibliography) from Leeds to Anglia and that worked as well.

Dec 27, 2010 at 1:12 AM

Would you be able to send the XSLT?

Would really appreciate it.

Dec 27, 2010 at 7:46 AM

Mail me directly (my address is at the top of the stylesheets normally) as I don't have your address.