ISO 690 - Numeric Reference with Square Brackets - Sorting by name not by appearance order in text

May 13, 2010 at 9:25 AM

Hi guys;

I have a problem with bibliography index. I'm writing my thesis in Persian, so there will be both Persian and English references in my thesis. I want to sort bibliography index by name so that English and Persian references to be separated (English References on top of Persian ones or vice versa). Also I want to use "ISO 690 - Numeric Reference with Square Brackets" style (downloaded from here), The problem is that I'm not familiar with XML script to do that myself and there is no such option for this style :( !

Any help would be appreciated

Thanks in advance

 

 

Coordinator
May 13, 2010 at 10:53 AM

You are talking about one of the styles that come with Word 2007, not a BibWord one. Personally, I don't work with those styles anymore, because they are too hard to manage.

Luckely what you want is probably confined to a small portion of the style. Assuming you set the language of your sources correctly (you can't do this in Word 2010, only in Word 2007 and 2008), you could extend the sort options to first start with the b:LCID field. Look for all occurrences of

<xsl:sort select="b:SortingString" />

and at the following line above them:

<xsl:sort select="b:LCID" />

(I have not tested the above suggestion)

May 13, 2010 at 1:20 PM

Thanks for your reply Yves;

Unfortunately I'm using Word 2010, and according to what you said it doesn't applicable on this version of Word. You mean the XML Style files are different in Word 2007 and Word 2010, and I can't use your suggestion in Word 2010, is it right?

 

Coordinator
May 13, 2010 at 2:42 PM

No, the xml is the same. The problem is with the input dialog.

In Word 2007 you can set the language (LCID) of your source. In the "Edit Source" dialog, there is a dropdown box in the upper right corner. In the betas of Word 2010 I use(d), that box was removed and there doesn't seem to be an option to add your language (LCID) any other way. Based on that, I assume that there isn't such a box in the final version. Without that box, I have no idea how you would indicate which sources are in English, and which ones are Persian.

I exchanged emails on this subject with the programmers responsible for this feature in Word, but I don't know if they listened to my feedback or not. My guess would be they didn't as the language box also introduced some translation issues.

May 13, 2010 at 10:10 PM

Thanks agian Yves;

I think I should switch back to Word 2007, after all the new Word 2010 seems to have some issues.

Sep 30, 2011 at 3:23 AM
Edited Oct 1, 2011 at 2:29 PM

Maybe a bit late to reply here, but as I had a similar problem right now (the bibliography should cite pages, etc. in the language of the source, i.e.: p/pp (pages) S (Seiten)) and have just switched recently from O2k7 to O2010 I was a bit confused about the fact that my old entries that had an assigned b:LCID value showed up with the dropdown box in O2010  and others not.

So I  added the old sources  from my doc file to the master list and then I looked in the Sources.xml file and voila - all entries that were O2007 had a <b:LCID>#</bLCID> tag, those from O2010 not. And the Source Dialog  is only showing the requester if the field has a number different from 0. But even if the LCID Value is present, the dropdown box will only show options for: default (0), Application LCID (in my case 1031) and the LCID from the source. For a "dirty"  workaround (alike to DOI fields, etc. which they introduced (and were inspired from here?) with SP1 but only updated the 1033 Bibform.xml (so even with the new styles my Bibform were not updated and I had to copy those fields from a 1033 one)) I included the b:LCID tag in there.

And that seem to work fine for now (and shouldn't really break anything, as the b:LCID field is not a "custom" tag but an already known one for the application).

EDIT: Ok, as I now was puzzled why O2010 ain't showed me the Table of Authorities field and found out that this Option only shows up in the Ribbon if Word is configured to include a language wich may utilize that one - so under Options Language I included English(US) and the TA Field became visible after a restart and what a coincidence also in the Bibliography Source Manager the DropDownBox where there for new entries with all the languages word is configured for (I've tested that with some others tongues to be sure).