Check of "allow row to break across pages"

Apr 15, 2010 at 1:19 PM

Hi.

I have a two-column reference list setup, and I have citations breaking across pages. I do not like this, and I can force the table to keep the rows by checking off "allow row to break across pages". However, upon refreshing the reference list, the setting is back again... Is it possible to change once-and-for-all?

Thank you very much for a fantastic script.

/Jakob

Coordinator
Apr 15, 2010 at 2:46 PM
Edited Apr 15, 2010 at 2:49 PM

Doubtful.

The output of the stylesheet is HTML. As HTML doesn't know the concept of pages, I doubt there is some HTML/CSS setting which would translate to the Word option for "allow row to break across pages".

A similar issue exists when the first column isn't width enough and you have to set it by hand after each update. I have been looking to output WordML rather than HTML by wrapping the WordML inside the HTML but without luck so far.

Coordinator
Apr 15, 2010 at 5:41 PM

I have to correct myself here. Now that I had some time to look into the issue, I found that there is a CSS parameter to 'disable' breaks. More important, it looks like Word even understands it.

In the source of the xsl, look for:

<tr>

and replace it by:

<tr style="page-break-inside:avoid">

Hope this helps.

Apr 16, 2010 at 6:56 AM

It works! Thank you very much for your very fast response.