Possible Font Error with IEEE_Reference Styles?

Mar 18, 2010 at 6:03 AM

Hello everyone,

First of all, I'd like to stay that I'm new here, and still somewhat of a novice when using Microsoft Word 2007 styles.  I'm currently writing my MS thesis, and came across the IEEE_Reference style within this package: http://bibword.codeplex.com/releases/view/15852#ReviewsAnchor

It is a lifesaver!  My only qualm is something odd I regarding formatting inheritance of the in-text citations.

I noticed that when I change the font format of "Heading 2" in word, it changes the font format of the in-text references. For example, if I use underlined or italicized font in "Heading 2", it applies this to the references. I haven't noticed this with other headings.  Is there an easy way to fix this? Or, perhaps I'm unaware of something going wrong on my end.


Any help would be greatly appreciated, as I'm trying to finish this by a quickly approaching deadline *eek*

Thank you in advance,

Paul

Coordinator
Mar 18, 2010 at 7:50 AM

In-text citations cannot be assigned a style from inside the xsl. Word gets rid of most styling information when inserting the transformation result. As a result it is for example not possible to provide superscripted in-text citations through a stylesheet. I guess Microsoft picked this approach as in-text citations tend to be part of a paragraph.

As to why you see the behaviour that you see, some of your styles must be linked in some way. It's a common error in IEEE templates (they probably all originate from the same master document containing the issue).

There are 3 possible solutions:

  1. Fix your template. If you find out what style is going haywire, you might be able to fix it.
  2. Disable linking of in-text citations. Look for <citation_as_link> in the xsl and set the value to no. Similar reports on this issue showed that the hyperlinking is somehow affected by other styles.
  3. Apply a macro overwriting all in-text citation formatting information. See http://bibword.codeplex.com/wikipage?title=Styles_FAQ#Q9 for the macro. This macro sets all in-text citations to superscript, you might want to change the line responsible for that into something more appropriate (you could even try just removing it to see if that fixes things). The line is:
    s.Font.Superscript = True

 

Mar 18, 2010 at 4:57 PM
Edited Mar 18, 2010 at 5:05 PM

Hello yves,

Thank you for the speedy response.

1. This sounds like a good option.  Unfortunately, I'm not sure how to do this.  Is the template a master word document located somewhere?  I'm a noob to xsl code, but see that the line <xsl:template ...> occurs quite often; I assume this is referencing the above said template.

2. I did this, and it worked.  Unfortunately, I need my citations to be linked between in-text and the reference page for university approval.

3. Do I apply the macro within the IEEE_Reference style sheet, at the end?  I've never used them before.

 

Thank you again!

EDIT: I just figured out how to use (3), and it seems to work if I simply remove the following line: s.Font.Superscript = True.

Coordinator
Mar 18, 2010 at 5:44 PM

Regarding 1: It has nothing to do with the xslt, it has to do with the document template (dot, dotm) you started from. This could even be an existing document of which you deleted the content and then started again. Somewhere in there, there must be a connection which links styles together resulting in the behaviour you observe.

Regarding 3: You can apply this whenever you want. If you add a new citation (or after you added a dozen new citations), you should just reapply the macro. It just applies the same style to all in-text citations whenever it is executed.

Mar 23, 2010 at 11:08 AM

Hi, yup I have the same problem.  My in text reference is some how related to heading two.  I would rather keep the hyperlink, and not have to dabble in macros.  

Since I know that the heading two is affecting the problem, is there a way to break the link to intext citations?.  I have tried style inspector and modifying styles but I am still unaware of how to break the link.  

If I change the referencing style to ISO numerical reference the intext citation is completely ok.  This leads me to the question of why the ISO numerical would be fine but the IEEE reference order causes this change (as it is based on the iso numerical order).  

I did however start my document of with another document from which I deleted certain parts.  And the problem does disappear when I start my own document and set my own styles.  Perhaps this problem can be traced to the templates provided by the IEEE http://www.ieee.org/web/publications/authors/transjnl/index.html#template.  Since this template is quite widespread, there should be a simple way to remove the linking.

Either way I would like to know how to break the link between the heading 2 styles and the intext reference, without having to resort to excessive coding or macros.

Thanks for the Referencing order.

Regards

Coordinator
Mar 23, 2010 at 3:24 PM

Add hyperlinking to the ISO numerical reference style and you will see the same behaviour. It's the hyperlinking that is causing the behaviour.

A reference style outputs HTML which is then converted by Word to WordML. You don't have any control on how that conversion happens. For some dark mysterious reason, the <a> tag used to allow hyperlinking from in-text citations gets translated into "Heading 2 Char" style on that IEEE document.

To make matters worse, you have limited to no options for formatting in-text citations through the reference style. Word tends to remove any formatting information with the exception of the most basic (i, b, u). An illustration of this behaviour is the inability to add superscripted in-text citations through the xslt. So defining your own style in the IEEE reference style to overwrite the current behaviour is not possible.

If you want to solve this through the styles in Word, I can think of only one way. Remove the "Heading 2" style and create a new one. Either don't make it linked, or link it to another style than the "Heading 2 Char" character style. Then change the "Heading 2 Char" style (which is now no longer linked to the "Heading 2" linked style) to follow normal formatting. As to how to delete a linked heading style in Word, you will have to check with someone who is more knowledgable about Word than I am.